Fast Crypto News

MetaMask warns of security vulnerability from older versions of popular crypto wallet1 min read

Jun 15, 2022 < 1 min

MetaMask warns of security vulnerability from older versions of popular crypto wallet1 min read

Reading Time: < 1 minute

“Ultimately, we’ve learned that our password encryption feature’s security was partially undermined by browser behavior,” said the team at MetaMask.

Your email address will not be published. Required fields are marked *